T8PLUS No video on any HDMI

Post Reply
Hayabusa2426
Posts: 1
Joined: Wed Jun 05, 2024 3:45 am

T8PLUS No video on any HDMI

Post by Hayabusa2426 »

I just purchased a T8Pro is the first time I turn it on but in no HDMI port do I have video, I already tried with different cables and in another minitor and on TV. It doesn’t even enter the bios, it’s totally dead, it’s just the LED on. I hope you can support me, thank you. :(
User avatar
Gabe
Senior Moderator
Senior Moderator
Posts: 1888
Joined: Fri Apr 17, 2020 1:19 am
Has thanked: 37 times
Been thanked: 105 times

Re: T8PLUS No video on any HDMI

Post by Gabe »

I would contact barry777, a tech for the company, at barry@minipcunion.com. He may ask for an order number, so I would include that, just in case.

It's possible that a BIOS disharge would solve the issue, but being that there is no instructional video for the procedure with the T8 Pro (nor the T8 Plus), it would be something they would have to provide instructions for.
W8 Pro • GK1 • AK3 • AM02 • T6 Pro • AMR5 • GK3 Pro • AD03 • AM06 Pro • T8 Pro • S1 • T8 Plus • CK10
I have no connection to ACEMAGIC other than being a customer and long time forum member
User avatar
barry777
Posts: 982
Joined: Thu Mar 02, 2023 1:08 am
Has thanked: 32 times
Been thanked: 75 times

Re: T8PLUS No video on any HDMI

Post by barry777 »

First, disconnect all peripherals (including the power adapter), press and hold the power button for 40 seconds, and then connect the power adapter and HDMI display to try to turn on the computer;
2. Replace other HDMI cables or other HDMI interfaces before turning on the computer.
If there is still no response, please provide the purchase order number and the fault video and send it to the email address: barry@minipcunion.com. We will further assist you in fixing the problem after verification.
Post Reply

Return to “N5095(T8Pro)”